Sniped! - The new addition to the JadeFalc. Armory

Selling, buying, shopping for and/or trading water blasters.
User avatar
Iceman
Posts: 263
Joined: Sun Jul 04, 2004 3:00 pm
Location: Pennsylvania, USA

Post by Iceman » Thu Jul 22, 2004 4:24 pm

Im driving by DON's house right now to see if it has arrived. DON if you can read this at camp, Im posting back l8tr on if it has arrived.
_

DoubleONothing
Posts: 55
Joined: Sat Jul 10, 2004 8:34 pm
Location: A small ringworld 25,000 light years from earth.
Contact:

Post by DoubleONothing » Sat Jul 24, 2004 12:11 pm

It hasn't. And I'm home now.

EDIT: I forgot to pay and either this wendsday (sp) or next The seller goes on a 3 week vacation.




Edited By DoubleONothing on 1090689136
SILENCE

User avatar
Iceman
Posts: 263
Joined: Sun Jul 04, 2004 3:00 pm
Location: Pennsylvania, USA

Post by Iceman » Sat Jul 24, 2004 3:46 pm

Id get paying, i want to work on that new soaker! :p
_

DoubleONothing
Posts: 55
Joined: Sat Jul 10, 2004 8:34 pm
Location: A small ringworld 25,000 light years from earth.
Contact:

Post by DoubleONothing » Sat Jul 24, 2004 7:26 pm

Payed. Let's hope I didn't miss them.

EDIT: Recieved an Email from Seller KVCrafty. It will ship on monday and may take up to a week to get here from California.




Edited By DoubleONothing on 1090717701
SILENCE

User avatar
Iceman
Posts: 263
Joined: Sun Jul 04, 2004 3:00 pm
Location: Pennsylvania, USA

Post by Iceman » Sun Jul 25, 2004 10:00 am

DoubleONothing wrote:Payed. Let's hope I didn't miss them.

EDIT: Recieved an Email from Seller KVCrafty. It will ship on monday and may take up to a week to get here from California.
Thats good news. it may take quicker than a week but yeah that sounds about right from his/her location. Boy i cant wait to work on it :D
_

DoubleONothing
Posts: 55
Joined: Sat Jul 10, 2004 8:34 pm
Location: A small ringworld 25,000 light years from earth.
Contact:

Post by DoubleONothing » Sun Jul 25, 2004 11:17 am

Oh cut it out. You can test it when we work on it. But otherwise...


IT'S MINE!
SILENCE

Nick
Posts: 129
Joined: Fri Jul 30, 2004 9:18 am
Location: Strensall, York, England

Post by Nick » Tue Aug 03, 2004 7:03 am

I had a 1500 but it broke, along with my 1000, 2000 and 2500.All suffered the leak when you pump problem and I don't/didn't know how to fix it. I dunno if it was because the trigger wasnt smooth. Mebbe I should have put grease on the trigger metal bitty thingy. Luckily they've changed the desgign on the monsters now so they are smoother and won't break.:cool:

User avatar
Falcon
Posts: 148
Joined: Wed Jul 07, 2004 2:40 am
Location: Sydney, Australia

Post by Falcon » Wed Aug 04, 2004 3:23 am

Nick wrote:I had a 1500 but it broke, along with my 1000, 2000 and 2500.All suffered the leak when you pump problem and I don't/didn't know how to fix it. I dunno if it was because the trigger wasnt smooth. Mebbe I should have put grease on the trigger metal bitty thingy. Luckily they've changed the desgign on the monsters now so they are smoother and won't break.:cool:

My CPS 1700 was starting to show signs of that problem. Sometimes, when I only wanted to fire a short burst, when I released the trigger it would continue to fire until the entire PC was empty. This was very annoying, so I took it apart to see what I could do about it. It turned out that all it needed was a rubber band to hold the trigger valve closed all the way. The rubber band should be quite thick, so it won't come off. My 1700 hasn't had a problem since I repaired it, and it works like new (well, it is only a month or so old anyway :goofy: ). Whatever you do, make sure you fix those soakers. To lose 3 legendary 98s and a CPS 2000 to something as simple as that would be a tragedy.




Edited By Falcon on 1091607931

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 4 guests